•   over 2 years ago

Having problems testing with Echosim.io

Hi, I wanted to know if anyone else was having problems testing their Skill using the Echosim.io service. I managed to finish my skill on the 4th of May and I promptly submitted it for certification and also on devpost as instructed. I had earlier tried to use Echosim to test my skill but it proved to be too erratic and did not even recognize my skill. I was therefore forced to make a video using graphics and text showing how to interact with the Skill. I thought I was all set and in good position to claim one of the first 200 slots. My skill eventually passed certification and went live on the 6th of May. It was also on that day i received an email from devpost reminding us that they were 4 days to go and specifically stating that the video must be done using either a real Echo device or the Echosim simulator. I therefore tried again to use the Echosim simulator and after a lot of struggle finally managed to get it to recognize my Skill (problem was with language setting).
The problem i'm encountering now is that the Echosim simulator does not seem to support conversational style Skills very well (if at all). I can get it to open my skill but any response i give seems to be interpreted as a new request to Alexa i.e. i can never get past the first interaction after invoking the Skill. It simply says "Expects speech" and nothing i do can get it to respond appropriately. My skill has already passed certification and is live and i have checked the lambda logs and found no error and is working perfectly with the service simulator. The only explanation is either the response is timing out due to network problems or the Echosim simulator does not support that type of interaction model.
I therefore wanted to know if its working properly for anyone else and if not can the competition organizers provide any clarification or guidance on what to do since i don't have a real Echo device.
I'm very frustrated because after all the hard work this delay may cost me a slot or even prevent me from submitting if i can't get a solution. Thank you for your time.

  • 6 comments

  •   •   over 2 years ago

    I had same problem with the Echosim simulator. It closes sections automatically and not appropriate for interaction style Skills. My impression is that testing on a device is best.

  •   •   over 2 years ago

    Thanks for the information. At least its good to hear i'm not the only one who has encountered this issue. But that still leaves me with no solution as i can't get hold of a real Echo device. I hope i will get an official response before the deadline.

  •   •   over 2 years ago

    Ok. There are number of options for you, since you are already certified:
    1. You can borrow a Dot from someone, test and record your skill.
    2. Seek help in the forum for someone who can test and record you skill for you. You can decide if you want full video or just an mp3. I think with these, you can either join with yours or use the full video.

  • Manager   •   over 2 years ago

    Hey Everyone,

    I'm sorry you're having trouble with Echosim! The Amazon mobile app also has Alexa. You can use that to demo your skill.

    All the best,
    Stefanie

  •   •   over 2 years ago

    Thanks @Udochukwu for all the advice and thank you Stefanie for the official response. I actually managed to get it working on the Echosim (barely). The problem was my network connection was not fast enough, so i used a faster network and also tried to speak quickly and use the least amounts of words that my skill responses could handle. Took 3 hours to record a 3 min video but at least its done. Thanks

  • Manager   •   over 2 years ago

    I'm sorry it took so long, but I'm really glad to hear you got it to work.

    When you're publishing your YouTube or Vimeo video, make sure they are set to be public and to allow playback on other websites. That will allow them to embed in your Devpost submission.

    Best of luck!
    Stefanie

Comments are closed.